Absa Bank Service Status
Absa Rewards services unavailable.
Incident Report for Digital Channels Service
Resolved
This incident has been resolved.
Posted Sep 25, 2024 - 20:39 SAST
Investigating
Absa Rewards services are temporarily down. We are working on the issue as a matter of urgency. We thank you for your patience and apologise for any inconvenience. Auth FSP
Posted Sep 25, 2024 - 12:53 SAST
This incident affected: Cellphone Banking (USSD) (Absa Rewards), Absa Online Banking - Full Service (Absa Rewards), Express Online Banking (Absa Rewards), and Absa Banking App (Absa Rewards).