Absa Bank Service Status
AVAF accounts and services unavailable.
Incident Report for Digital Channels Service
Resolved
This incident has been resolved.
Posted Apr 20, 2024 - 13:46 SAST
Investigating
All our AVAF services are temporarily down. We are working on the issue as a matter of urgency. We thank you for your patience and apologise for any inconvenience. Auth FSP
Posted Apr 20, 2024 - 06:15 SAST
This incident affected: Express Online Banking (AVAF services.), Absa Online Banking - Full Service (AVAF services.), and Absa Banking App (AVAF services.).