Absa Bank Service Status

Absa Banking App unavailable.

Incident Report for Digital Channels Service

Resolved

This incident has been resolved.
Posted Jun 22, 2025 - 17:35 SAST

Update

We are continuing to investigate this issue.
Posted Jun 22, 2025 - 17:23 SAST

Investigating

Absa Banking App is temporarily down. We are working on resuming the service as soon as possible. You can still transact on Absa Online banking (Express and Full Service). We apologise for the inconvenience. Auth FSP
Posted Jun 22, 2025 - 16:58 SAST
This incident affected: Absa Banking App (App Login, Payments, CashSend and CashSend Plus, IIP: Immediate Interbank Payment, PayShap - Rapid Payment Program, Buy Airtime and Data, Buy Electricity, Play Lotto, Absa Rewards, Verification message - 2FA_SureCheck, Western Union/SWIFT/Currency Investment Accounts, AVAF services.) and Cellphone Banking (USSD) (Login, Buy Prepaid Data and Airtime, Buy Prepaid Electricity, Absa Rewards, CashSend, Play Lotto).