Absa Bank Service Status

Digital banking services temporarily unavailable.

Incident Report for Digital Channels Service

Resolved

This incident has been resolved.
Posted Jun 22, 2025 - 16:56 SAST

Investigating

All our digital banking services are temporarily down. We are working on the issue as a matter of urgency. We thank you for your patience and apologise for any inconvenience. Auth FSP
Posted Jun 22, 2025 - 16:55 SAST
This incident affected: Absa Banking App (App Login) and Cellphone Banking (USSD) (Login).