Absa Bank Service Status
Degradation of service.
Incident Report for Digital Channels Service
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 20:58 SAST
Investigating
We apologise to our customers who are experiencing slow responses and account balance issues on our Digital Banking platforms. We appreciate your patience while we investigate and resolve the problem. Auth FSP
Posted Feb 21, 2024 - 20:46 SAST