Absa Bank Service Status
Services Degraded
Incident Report for Digital Channels Service
Resolved
This incident has been resolved.
Posted Jun 25, 2021 - 15:47 SAST
Investigating
Our digital banking services are currently degraded. We are working hard to restore stability. We apologise for the inconvenience.
Posted Jun 25, 2021 - 13:39 SAST