Absa Bank Service Status
Services Unavailable
Incident Report for Digital Channels Service
Resolved
Our digital banking services are working again! Thank you for your patience.
Posted Apr 14, 2021 - 15:49 SAST
Update
We are continuing to investigate this issue.
Posted Apr 14, 2021 - 15:16 SAST
Investigating
All our digital banking services are temporarily down. Please bear with us, we are attending to the issue and we'll inform you when we are up and running again. You can still transact via ATMs, branches and point-of-sale machines. We apologise for any inconvenience.
Posted Apr 14, 2021 - 15:04 SAST