Absa Bank Service Status
Services Unavailable
Incident Report for Digital Channels Service
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 11:34 SAST
Investigating
We apologise to our customers who are experiencing issues with our Digital Banking platforms. Thank you for your patience while we investigate the problem.

We are working hard on restoring the service for you as soon as possible. You will be informed as soon as the issue has been resolved.
Posted Apr 09, 2021 - 11:29 SAST
This incident affected: Express Online Banking (Payments), Absa Online Banking - Full Service (Payments), Absa Banking App (App Login, Payments, Buy Airtime and Data, Buy Electricity, Play Lotto), Cellphone Banking (USSD) (Login), and ChatBanking - Whatsapp & Facebook Banking (Payments).